Jpilot jIRC applet only supports Netscape4.0 and IE4.0 or above.
You must choose "Yes" when it asks you to install, or you cannot chat.